exchanging

مشكل در عوض كردن پسوند آرشيو از html به php

شروع موضوع توسط root ‏2 آگوست 2004 در انجمن MovableType - مووبل تایپ

  1. root

    root Registered User

    تاریخ عضویت:
    ‏29 آگوست 2003
    نوشته ها:
    154
    تشکر شده:
    2
    سلام . من اين پسوند فايل ها رو از html به php كه تغيير دادم در ام تي پريفرنس سايت . وقتي ميخوام اينديويژوال ارشيو رو ببينم internal server error 500 ميده .
    براي اينكه اين مشكل رو حل كنم بايد برم توي /weblog/archives/ بعد پرميشن مطلب رو به 755 تغيير بدم .
    راهي هست كه ديگه من اينكار رو نكنم ؟ تا ديگه اين اررور رو هم نده ؟
     
  2. knowhow

    knowhow مدیران قدیمی

    تاریخ عضویت:
    ‏25 دسامبر 2002
    نوشته ها:
    3,477
    تشکر شده:
    19
    شما اولا فولدرهات رو يك بار permissionشون رو بکن 755 با این کار دیگه این permission فولدر ها عوض نمی شه.
    برای فایلها هم فایل mt.cfg رو باز کن یک جا نوشته Mtuploadperm = 777 فکر کنم دو خط است که در مورد permission است اونجا # های اول خطها رو بردار و هر دو رو بکن 644 حالا از این به بعد فایلهایی که MT می سازه می شه 644 و مشکل حل می شه ولی فایلهای قبلی تغییر نمی کنه می تونی یک بار همه فایلها رو پاک کنی و mt رو rebuild کنی.
     
  3. root

    root Registered User

    تاریخ عضویت:
    ‏29 آگوست 2003
    نوشته ها:
    154
    تشکر شده:
    2
    دستت درد نكنه برم ببينم جواب ميده يا نه ؟ منتهي فكر كنم 644 باشه ميخوام بشه 755 چون پي اچ پيه ديگه ؟
     
  4. ehsan

    ehsan Administrator

    تاریخ عضویت:
    ‏5 دسامبر 2002
    نوشته ها:
    7,915
    تشکر شده:
    3,513
    محل سکونت:
    Internet
    برای فایلهای php میتونی روی 644 تنظیم کنی. ولی برای کل دایرکتوری باید روی 755 تنظیم کنی.
     
  5. root

    root Registered User

    تاریخ عضویت:
    ‏29 آگوست 2003
    نوشته ها:
    154
    تشکر شده:
    2
    دستتون درد نكنه . مشكل من با همون روشي كه گفتين حل شد . پير شي جوون ...
     
  6. Mahdi_Nasiri

    Mahdi_Nasiri کاربر تازه وارد

    تاریخ عضویت:
    ‏20 آپریل 2005
    نوشته ها:
    27
    تشکر شده:
    0
    محل سکونت:
    Tehran
  7. shinystar

    shinystar کاربر تازه وارد

    تاریخ عضویت:
    ‏28 مارس 2005
    نوشته ها:
    12
    تشکر شده:
    0
    محل سکونت:
    Tehran
    سلام دوستان. من یه مشکل نسبتا بزرگ دارم با این پرمیشن ها
    مساله اینجاست که من پلاگین فتوگالری رو نصب کردم. حالا هروقت که آلبوم جدیدی درست میشه و یا عکس جدیدی آپلود میشه چند تا فایل پی اچ پی با پرمیشن 664 ساخته میشن که باعث میشه صفحه گالری دیده نشه. مجبورم بعد هر بار آپلود دستی همه فایلهای پی اچ پی رو 755 کنم. کسی میتونه کمک کنه؟:( :(