منتخب بازارچه

برگزیده های پرشین تولز

مشکل تو سایت مپ ؟!!!

Mahiar0

کاربر افتخاری سئو و معرفی سایتها
تاریخ عضویت
20 جولای 2004
نوشته‌ها
10,282
لایک‌ها
1,206
محل سکونت
رشت
تو
ابزار گوگل
تو سایت مپ
این ادرس
http://www.linkarea.us/sitemap.xml
میزنم ارورمیده
توی این که میگه برید
چک میکنه

http://feedvalidator.org/check.cgi?url=http://www.linkarea.us/sitemap.xml

ارور میده


Sorry
This feed does not validate.

•line 2, column 0: Undefined root element: urlset [help]

<urlset xmlns="http://www.google.com/schemas/sitemap/0.84"> In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendations.

•"application/xml" media type is not specific enough [help]

•line 2, column 0: Use of unknown namespace: http://www.google.com/schemas/sitemap/0.84 [help]

<urlset xmlns="http://www.google.com/schemas/sitemap/0.84">

چی باید کرد؟

برای RSS و Atomرو ایرادی نمیگیره ودرست است
 

balabala

کاربر قدیمی پرشین تولز
کاربر قدیمی پرشین تولز
تاریخ عضویت
22 می 2005
نوشته‌ها
8,130
لایک‌ها
4,730
سن
39
محل سکونت
یه خورده اونورتر
خط urlset رو بکن این:
HTML:
<urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.sitemaps.org/schemas/sitemap/0.9 http://www.sitemaps.org/schemas/sitemap/0.9/sitemap.xsd">
 

Mahiar0

کاربر افتخاری سئو و معرفی سایتها
تاریخ عضویت
20 جولای 2004
نوشته‌ها
10,282
لایک‌ها
1,206
محل سکونت
رشت
خط urlset رو بکن این:
HTML:
<urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.sitemaps.org/schemas/sitemap/0.9 http://www.sitemaps.org/schemas/sitemap/0.9/sitemap.xsd">
یعنی این رو پاک کنم؟
<urlset xmlns="http://www.google.com/schemas/sitemap/0.84">

به جاش اینی که شما دادی بگذارم؟
الان گذاشتم اصلا دیگه باز نمیکنه؟
یکجاش اشتباهه!!
 

balabala

کاربر قدیمی پرشین تولز
کاربر قدیمی پرشین تولز
تاریخ عضویت
22 می 2005
نوشته‌ها
8,130
لایک‌ها
4,730
سن
39
محل سکونت
یه خورده اونورتر
یعنی این رو پاک کنم؟
<urlset xmlns="http://www.google.com/schemas/sitemap/0.84">

به جاش اینی که شما دادی بگذارم؟
الان گذاشتم اصلا دیگه باز نمیکنه؟
یکجاش اشتباهه!!
دقت بکن چون من ادیتش کردم شاید قبلی رو گذاشتی. ولی رجوع بکن به پست قبلیم نیز :D
/
ادیت:
اینو نذاشتی:
کد:
[COLOR=#0000ff]<urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9[COLOR=red][B]"[/B][/COLOR] .......[/COLOR]
 
Last edited:

Mahiar0

کاربر افتخاری سئو و معرفی سایتها
تاریخ عضویت
20 جولای 2004
نوشته‌ها
10,282
لایک‌ها
1,206
محل سکونت
رشت

Mahiar0

کاربر افتخاری سئو و معرفی سایتها
تاریخ عضویت
20 جولای 2004
نوشته‌ها
10,282
لایک‌ها
1,206
محل سکونت
رشت

balabala

کاربر قدیمی پرشین تولز
کاربر قدیمی پرشین تولز
تاریخ عضویت
22 می 2005
نوشته‌ها
8,130
لایک‌ها
4,730
سن
39
محل سکونت
یه خورده اونورتر
نه بابا وقتی بگه سایت validه مشکلی نیست. این سایته که میگی برای منم میگه اشتباهه! ولی خود گوگل اد کردم اروری نداده.
/
میدونی سایتت فیل*تره :blink:
 

Mahiar0

کاربر افتخاری سئو و معرفی سایتها
تاریخ عضویت
20 جولای 2004
نوشته‌ها
10,282
لایک‌ها
1,206
محل سکونت
رشت
نه بابا وقتی بگه سایت validه مشکلی نیست. این سایته که میگی برای منم میگه اشتباهه! ولی خود گوگل اد کردم اروری نداده.
/
میدونی سایتت فیل*تره :blink:

اوکی ممنون
هنوز peding تایید شد معلوم میشه مشکلی نداره

اره بهتر ف*یل تره
ایرانی نمیاد:D
 

Mahiar0

کاربر افتخاری سئو و معرفی سایتها
تاریخ عضویت
20 جولای 2004
نوشته‌ها
10,282
لایک‌ها
1,206
محل سکونت
رشت
بازم ارور داد گوگل
قبول نکرد
2yxq5hk.jpg


http://i43.tinypic.com/2yxq5hk.jpg
 

balabala

کاربر قدیمی پرشین تولز
کاربر قدیمی پرشین تولز
تاریخ عضویت
22 می 2005
نوشته‌ها
8,130
لایک‌ها
4,730
سن
39
محل سکونت
یه خورده اونورتر
خب اررورش مربوط به اون نیست. میگه همه لینکهات always هستن. تگ changefreq لینکهات رو بکن daily یا weekly الان همشون alwaysن.
 

Mahiar0

کاربر افتخاری سئو و معرفی سایتها
تاریخ عضویت
20 جولای 2004
نوشته‌ها
10,282
لایک‌ها
1,206
محل سکونت
رشت
الان طبق این اموزش
http://forum.movable-type.ir/-t3571p2.html?&highlight=sitemap

رفتم سایت مپ درست کردم با ام تی که نصب است
تو گوگل هم ادد کردم
الان این ارور رو میده!!
2qcfggx.jpg


یکیش ارور میده لینکها زیاده!!

کلا معلوم نیست اینبار چه عادی چه با ام تی درست میکنم برای سایت مپ گیر میده اون زمان که rss اینها نگذاشته بودموهمین سایت مپ ساده دستی گذاشتم گیر نمیداد الان همین دستی هم گیر میده:(
 

balabala

کاربر قدیمی پرشین تولز
کاربر قدیمی پرشین تولز
تاریخ عضویت
22 می 2005
نوشته‌ها
8,130
لایک‌ها
4,730
سن
39
محل سکونت
یه خورده اونورتر
اولین ارور میگه همه لینکهات priority یکسان دارن. برای لینک اصلی بگذارش 1.0 برای بعدی ها 9.0 ، 8، 7 ، این اعداد رو استفاده کن.
خطای دوم هم میگه اول فایلت whitespace داره. با یه ادیتور مثل notepad++بازش کن کاراکتر اول فایل رو پاک کن.
 

Mahiar0

کاربر افتخاری سئو و معرفی سایتها
تاریخ عضویت
20 جولای 2004
نوشته‌ها
10,282
لایک‌ها
1,206
محل سکونت
رشت
اولین ارور میگه همه لینکهات priority یکسان دارن. برای لینک اصلی بگذارش 1.0 برای بعدی ها 9.0 ، 8، 7 ، این اعداد رو استفاده کن.
خطای دوم هم میگه اول فایلت whitespace داره. با یه ادیتور مثل notepad++بازش کن کاراکتر اول فایل رو پاک کن.

اوکی
ممنون
فاصله هم از بین بردم
بیشترشون که 1 بود رو کردم 0و8 و کاتاگورها رو هم 0.9 کرد

حالا ببینیم چی میکنه گوگل
 

Mahiar0

کاربر افتخاری سئو و معرفی سایتها
تاریخ عضویت
20 جولای 2004
نوشته‌ها
10,282
لایک‌ها
1,206
محل سکونت
رشت
فعلا که زدم قبول کرد همه رو
اینطوری بهتره سایت مپم هم کامله وشامل همه لینک ها میشه
 

Mahiar0

کاربر افتخاری سئو و معرفی سایتها
تاریخ عضویت
20 جولای 2004
نوشته‌ها
10,282
لایک‌ها
1,206
محل سکونت
رشت
الان
سایت عوض شده این rss مثلا
http://www.tafrihi.com/rss.php
تو ابزار گوگل ادش کردم ارور میده قبول نمیکنه این ارور رو میده؟
2s93tog.jpg


چی باید کرد؟
کداین صفحه هم این است
PHP:
<?
header("Content-Type: application/xml; charset=utf-8");
include ("yahoo.php");
echo '<?xml version="1.0" encoding="utf-8"?>

<rss version="2.0">
<channel>';
	$qca=mysql_query("select * from posts order by id desc limit 30");
?>

<title>Tafrihi.com</title>

<link>http://www.tafrihi.com</link>
<language>fa</language>

<generator>Tafrihi.com</generator>
<copyright>Tafrihi.com</copyright>
<?while(@$post = mysql_fetch_array($qca)){?>
<item>

<title><?=$post['title']?></title>

<link><?echo 'http://www.tafrihi.com/?p='.$post['id']?></link>
<description><?=$post['title']?></description>
<guid><?echo 'http://www.tafrihi.com/?p='.$post['id']?></guid>

</item>

<?
}
?>

</channel>

</rss>

تو اینجا هم این ارور رو میده
HTML:
http://feedvalidator.org/check.cgi?url=http%3A%2F%2Fwww.tafrihi.com%2Frss.php

این ارور رو؟
HTML:
Sorry
This feed does not validate.

•line 313, column 0: Missing channel element: description [help]

</channel>In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendation.

•line 313, column 0: Missing atom:link with rel="self" [help]

</channel>

راهنمایی کنید
 
بالا