آژانس هواپیماییfootbal
nexpay

مشکل در نصب بر روی لینوکس

شروع موضوع توسط icehess ‏26 ژوئن 2004 در انجمن MovableType - مووبل تایپ

  1. icehess

    icehess کاربر تازه وارد

    تاریخ عضویت:
    ‏10 ژانویه 2004
    نوشته ها:
    4
    تشکر شده:
    0
    سلام!
    یه مشکلی با نصب ام تی در لینوکس دارم(روی loccalhost). اون هم اینکه وقتی می خوام فایلهای cgi رو اجرا کنم (مثلا mt-load یا خود mt) پیغام هم اینطوری:
    Got an error: Can't locate MT/App/CMS.pm in @INC (@INC contains: /var/www/localhost/cgi-bin/mt/extlib /var/www/localhost/cgi-bin/mt/lib /etc/perl /usr/lib/perl5/site_perl/5.8.2/i686-linux /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.2/i686-linux /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.2/i686-linux /usr/lib/perl5/5.8.2 /usr/local/lib/site_perl .) at /var/www/localhost/cgi-bin/mt/mt.cgi line 21.
    (البته خودم دستی دیتابیس رو درست کردم و این پیغام رو میده!!
    برای mt-load هم اینو میگه:

    An error occurred while loading data:

    Can't find default template list; where is 'default-templates.pl'?
    Error: Can't locate MT/default-templates.pl in @INC (@INC contains: /var/www/localhost/cgi-bin/mt/extlib /var/www/localhost/cgi-bin/mt/lib /etc/perl /usr/lib/perl5/site_perl/5.8.2/i686-linux /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.2/i686-linux /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.2/i686-linux /usr/lib/perl5/5.8.2 /usr/local/lib/site_perl .) at /var/www/localhost/cgi-bin/mt/mt-load.cgi line 30.

    لطفا منو راهنمایی کنید. هر چه سزیع تر بهتر..ممنون!
     
  2. icehess

    icehess کاربر تازه وارد

    تاریخ عضویت:
    ‏10 ژانویه 2004
    نوشته ها:
    4
    تشکر شده:
    0
    جمیعا از انبوه پاسخهای ارسالی سپاس گزاری مینماید!
     
  3. mohammad57

    mohammad57 کاربر تازه وارد

    تاریخ عضویت:
    ‏21 آپریل 2004
    نوشته ها:
    124
    تشکر شده:
    0
    خواهش مي كنم قابلي نداشت
     
  4. ehsan

    ehsan Administrator

    تاریخ عضویت:
    ‏5 دسامبر 2002
    نوشته ها:
    7,914
    تشکر شده:
    3,492
    محل سکونت:
    Internet
    در مورد سوال اول... ببینم پرل درست روی سرور نصب شده؟

    در مورد سوال دوم هم خب فایل default_templates.pl سر جاش نیست. که خب این هم چند دلیل داره. یا اینکه فایلها رو در جای مناسب Upload نکردی یا اینکه دایرکتوری cgi-bin پرمیشن های لازم رو نداره یا از طرف وب سرور به عنوان یه دایرکتوری اجرایی شناخته نشده. خلاصه به گمونم بر می
    گرده به تنظیمات سرور.
     

این صفحه را با دیگران به اشتراک بگذارید

خرید بک لینکreviews عسل طبیعی و گرده گل ایرانی