چرا پارتیشن های هارد دوم دیده نمی شوند؟

شروع موضوع توسط Reza_Sadeghi ‏24 مارس 2007 در انجمن ویندوز

  1. Reza_Sadeghi

    Reza_Sadeghi Registered User

    تاریخ عضویت:
    ‏23 نوامبر 2004
    نوشته ها:
    334
    تشکر شده:
    6
    محل سکونت:
    زاهدان
    سلام
    مشکل به طور کلی استفاده هم زمان از 2 هارد در ویندوز XP است.

    هارد اول Maxtor 120 Plus به حالت Master روی IDE 1 نصب شده.
    هارد دوم Quantum 40 به حالت Slave روی IDE 1 نصب شده.

    Combo Drive به حالت Master روی IDE 2 نصب شده.
    CD Writer Asus به حالت Slave روی IDE 2 نصب شده.

    همه این Device ها به همین ترتیب داخل BIOS تنظیم شده و قابل مشاهده است.
    سیستم عامل باید از هارد اول Maxtor اجرا بشه و بقیه دسترسی داشته باشه.

    مشکل اینجاست که :
    وقتی وارد XP می شم همه درایو های هارد اول و Optical Drive ها قابل دسترسی است اما پارتیشن های هارد دوم دیده نمی شوند.
    از Device manager هم هارد دوم شناسایی نشده است.

    راه هایی که امتحان کردم :
    هارد اول به همان صورت و هارد دوم به IDE 2 نصب شد و هر دو Optical Drive ها رو برداشتم و این بار پارتیشن های هارد دوم هم در کنار هارد اول قابل مشاهده و دسترس بود اما من باید از هر 4 تا Device به صورت هم زمان استفاده کنم.

    راه حل پیشنهادی شما برای رفع این مشکل چیه؟
    کجای کار اشتباست؟
     
  2. خدمات پی پالبازدیدیار - افزایش بازدید سایت و سیگنال های برند
  3. R E Z A

    R E Z A کاربر تازه وارد

    تاریخ عضویت:
    ‏27 فوریه 2007
    نوشته ها:
    1,266
    تشکر شده:
    1
    محل سکونت:
    TeHrAn
    والا تا اونجایی که من میدونم برای قرار دادن 2 هارد علاوه بر اینکه Slave و Master باید تنظیم بشه باید جامپر پشت هارد دوم هم جاش عوض بشه. این موضوع رو هم تست کن.
     
  4. Reza_Sadeghi

    Reza_Sadeghi Registered User

    تاریخ عضویت:
    ‏23 نوامبر 2004
    نوشته ها:
    334
    تشکر شده:
    6
    محل سکونت:
    زاهدان
    ممنون از Reply ات.
    اما من همه جامپرهای هر 4 تا Device رو به همون طریقی که عرض کردم هم در پشت و هم در BIOS تنظیم کردم و کاملا از درست متصل شدنشون مطمئنم.

    در BIOS همه رو به درستی و سر جای خودشون نشون داده میشه اما ویندوز XP همه رو می شناسه الا هارد دوم که به صورت Slave روی Slot اول متصل کردم.

    نمی دونم باید چی کار کرد و ایراد از کجاست....تا حالا به چنین مشکلی برنخورده بودم.
     
  5. amin007110

    amin007110 کاربر فعال نرم افزار کاربر فعال

    تاریخ عضویت:
    ‏8 مارس 2004
    نوشته ها:
    3,692
    تشکر شده:
    37
    محل سکونت:
    No.20, Esfahan, Iran
    يعنی ميخوای بگی هر دو hard تو bios شناسايی ميشن ولی تو Device Manager حتی hard دوم رو نشون هم نميده ؟
    تعداد drive هات از Z بيشتر نشده ؟ Cable ها سالمن ؟ Primary و Secondry هر دو همين وضعيت رو دارن ؟ يعنی با جابجا کردن Device ها تغييری ديده نميشه ؟ آيا فقط اون hard توسط OS ديتکت نميشه يا اينکه اگه به اون کانال يه Device ديگه هم وصل بشه اونم شناخته نميشه ؟ وضعيت Cable Select به جای Master يا Slave رو امتحان کردی ؟ در مورد خوندن جدول Quantum 40 مطمئنی اشتباه نکردی ؟
     
  6. Reza_Sadeghi

    Reza_Sadeghi Registered User

    تاریخ عضویت:
    ‏23 نوامبر 2004
    نوشته ها:
    334
    تشکر شده:
    6
    محل سکونت:
    زاهدان
    دقیقا همین طوره...هر دو هارد در بایوس نشون داده می شوند اما هارد دوم در Device manager حتیDetect هم نمیشه.

    سعی کردم از ابزار Add new Hardware در Control Panel هم استفاده کنم و چندین مرتبه هم امتحان کردم اما نتیجه ای نداد.

    تعداد درایوها از Z بیشتر نیست.

    کابل ها سالمند چون با همون کابل ها وقتی هارد دوم رو از IDE 1 به IDE 2 بدون وجود optical Drive ها متصل کردم پارتیشن هاش در کنار پارتیشن های هارد اول قابل دسترسی بود و چندین فایل هم کپی کردم.

    در حال حاضر تنظیمات primary و Secondary به همون ترتیبی هست که در پست اول تاپیک اشاره کردم.

    سئوال : اگر این دفعه هارد ها رو به IDE 2 و Optical drive ها رو به IDE 1 متصل کنم به این ترتیب سیستم عامل توانایی این رو داره که از Secondary Slot بوت بشه؟

    جای کابل ها رو برای Device ها عوض کردم اما در کل تفاوتی نداشت.

    وضعیت cable Select برای M یا S رو تست نکردم چون در صورت حل شدن مشکل در نهایت باید از سیستم عامل هارد اول استفاده بشه ( این کارو امتحان می کنم.)

    جدول Quantum 40GB تا حدودی قدیمیه و راهنمای اتصال جامپر هاش روی خود هارد کاملا واضح و مشهود نیست. با این وجود هر سه حالت (master.slave.alone) رو با عوض کردن محل جامپرها امتحان کردم که در نهایت با توجه به شناسایی اون در BIOS در حال حاضر در وضعیت Slave روی Primary Slot قرار گرفته.

    خیلی عجیبه. :blink:
    ممکنه این مشکل ارتباطی به منبع تغذیه داشته باشه ؟ به این دلیل که چون هر 4 تا دستگاه در حال استفاده از ولتاژ هست منبع تغذیه کافی نیست یا این استدلال من غلطه ؟
    یا شاید این دو نوع هارد استثنا نمی تونن در چنین شرایطی با هم کنار بیان؟
    یا....؟

    نظر شما چیه؟
     
  7. amin007110

    amin007110 کاربر فعال نرم افزار کاربر فعال

    تاریخ عضویت:
    ‏8 مارس 2004
    نوشته ها:
    3,692
    تشکر شده:
    37
    محل سکونت:
    No.20, Esfahan, Iran
    خوب استدلالت ميتونه غلط نباشه. بستگی داره به مشخصات سيستم. ولی معمولاً اگه پاور ضعيف باشه بايد قطعات يکی در ميون شناسايی نشن.
    اون hard جدولش واضحه. مسأله اينه که طريقه خوندنش فرق ميکنه. تا يادم مياد جامپر کنار کابل ديتا مستر و سومی از همون سمت Slave بود. تو بعضی از تيپ ها بر عکسه ولی اغلب همينطوره. دومی هم CS.
    اگه مادربورد و bios جواب بده شما hard رو هر جا که وصل کنی مستقل از وضعيتش ميتونی براش Boot Priority رو تعريف کنی.
    فکر کنم بهتره هر 4 وسيله رو در وضعيت Cable Select قرار بدی(در مورد اپتيکالها جامپر سومه) و امتحان کنی. شک دارم که مستر Slave هارو اشتباه کرده باشی چون اگه اينجوری بود تو bios نبايد ديتکت ميشدن ولی به هر حال امتحان کن. يه بارم با 3 وسيله تست کن.
     
  8. Reza_Sadeghi

    Reza_Sadeghi Registered User

    تاریخ عضویت:
    ‏23 نوامبر 2004
    نوشته ها:
    334
    تشکر شده:
    6
    محل سکونت:
    زاهدان
    درست شد.
    بلاخره موفق شدیم این مشکل رو برطرف کنیم.
    HHD اول به IDE 1 به صورت Master و CD Writer به IDE 1 به صورت Slave
    HDD دوم به IDE 2 به صورت Slave و DVD Drive به IDE 2 به صورت Master متصل کردم و درست شد.
    طی این مدت درگیر تهیه کابل Data بلندتری بودم تا بتونم Device ها رو به هم مرتبط کنم چون فاصله Optical Drive ها با HDD ها زیاد بود امکان استفاده از
    کابل های استاندارد میسر نبود.
    این کابل 1 متری رو از فروشگاهی مربوط به تجهیزات و تعمیرات Printer در مشهد خیابان راهنمایی پیدا کردم.

    amin007110 عزیزاز راهنمایی و صحبت هات متشکرم.
     
  9. amin007110

    amin007110 کاربر فعال نرم افزار کاربر فعال

    تاریخ عضویت:
    ‏8 مارس 2004
    نوشته ها:
    3,692
    تشکر شده:
    37
    محل سکونت:
    No.20, Esfahan, Iran
    نکته: در صورت اتصال درايوهای اپتيکال و ​
    hard به يک کابل سرعت هارد تا يک چهارم پايين مياد.

     
  10. GreenRoad

    GreenRoad Registered User

    تاریخ عضویت:
    ‏5 ژوئن 2005
    نوشته ها:
    650
    تشکر شده:
    76
    آره نکته جالبی بود - ممنون
     
عسل طبیعی و گرده گل ایرانی