nexpay

یه مشکل در asp.net که نیاز به راهنمایه تو عزیز داره

شروع موضوع توسط ali00h ‏24 سپتامبر 2005 در انجمن asp , ASP.NET

  1. ali00h

    ali00h Registered User

    تاریخ عضویت:
    ‏27 آگوست 2005
    نوشته ها:
    95
    تشکر شده:
    0
    سلام من یه فضا خریدم وتوش صفحه asp.net اپلود کردم و جواب داده ولی وقتی یه صفحه که می خواست روی فایل xml چیز بنویسه رو اجرا کردم ارور داد که باید <identity impersonate="true" /> رو توی web.config بزاری ولی این بار برای اجرا از من usernameوpassword می خواد وقتی یوزر و پسورده FTP رو میزنم کار میکنه
    من این سایتو تویه یه فضای مجانی آپلود کردم و کار داد لطفا راهنماییم کنید چیکار کنم که از من یوزر و پسورد نخواد
    پیشاپیش ازتون متشکرم
     
  2. balabala

    balabala کاربر قدیمی پرشین تولز

    تاریخ عضویت:
    ‏22 می 2005
    نوشته ها:
    7,344
    تشکر شده:
    1,314
    محل سکونت:
    یه خورده اونورتر
    توي وب كانفيگ دسترسي users رو بكن *.
     
  3. balabala

    balabala کاربر قدیمی پرشین تولز

    تاریخ عضویت:
    ‏22 می 2005
    نوشته ها:
    7,344
    تشکر شده:
    1,314
    محل سکونت:
    یه خورده اونورتر
    authentication mode رو هم اگر هست Windows بکنش یا None یا Forms
     
  4. ali00h

    ali00h Registered User

    تاریخ عضویت:
    ‏27 آگوست 2005
    نوشته ها:
    95
    تشکر شده:
    0
    مي شه اينو بيشتر توضيح بدين دقيقا بايد چيكار كنم
    توي وب كانفيگ دسترسي users رو بكن *.

    authentication رو هم None كردم
     
  5. balabala

    balabala کاربر قدیمی پرشین تولز

    تاریخ عضویت:
    ‏22 می 2005
    نوشته ها:
    7,344
    تشکر شده:
    1,314
    محل سکونت:
    یه خورده اونورتر
    توي وب كانقيگ يك خط نوشته allow users اونرو هرچيزي مثل ? يا چيز ديگه هست بكن ستاره

    اونيكي هم كه none كرديد.
    خوب چيو ديگه توضيح بدم؟ يه امتحان بكنش...
     
  6. ali00h

    ali00h Registered User

    تاریخ عضویت:
    ‏27 آگوست 2005
    نوشته ها:
    95
    تشکر شده:
    0
    اين كه از اولشم همينطور بود
    <authorization>
    <allow users="*" />
    </authorization>
    و همچنان مشكل حل نشد
     
  7. balabala

    balabala کاربر قدیمی پرشین تولز

    تاریخ عضویت:
    ‏22 می 2005
    نوشته ها:
    7,344
    تشکر شده:
    1,314
    محل سکونت:
    یه خورده اونورتر
    الان شما مشكلت اينكه نمي خواي پسورد بگذاري؟ پسورد رو كجا وارد ميكني؟ ميتوني سايتتو نشونم بدي؟
     
  8. ali00h

    ali00h Registered User

    تاریخ عضویت:
    ‏27 آگوست 2005
    نوشته ها:
    95
    تشکر شده:
    0
  9. balabala

    balabala کاربر قدیمی پرشین تولز

    تاریخ عضویت:
    ‏22 می 2005
    نوشته ها:
    7,344
    تشکر شده:
    1,314
    محل سکونت:
    یه خورده اونورتر
    عجيبه؟ هاست شما چيه؟ حتما ويندوزه ديگه؟ سي پنل كه نداريد؟ اگر داريد بگيد.

    شبيه يك چيزي توي سي پنل هست كه خيلي راحت حل ميشه...
     
  10. ali00h

    ali00h Registered User

    تاریخ عضویت:
    ‏27 آگوست 2005
    نوشته ها:
    95
    تشکر شده:
    0
    من هاستم با كنترل پنل plesk هستش
    يعني مشكل از كنترل پنل؟
    بازم ميگم من وقتي يوزر و پسورد FTP رو توي اون كادر ميزنم صفحه درست كار ميكنه
     
  11. balabala

    balabala کاربر قدیمی پرشین تولز

    تاریخ عضویت:
    ‏22 می 2005
    نوشته ها:
    7,344
    تشکر شده:
    1,314
    محل سکونت:
    یه خورده اونورتر
    ببين به پلسك وارد نيستم ولي توي سي پنل يك آپشن هستش: Password Protected Directories كه براي من هم چون يكي از فولدر ها پسورد داشت اينطور ميشد.
    در ضمن شما بگو permission فولدرت چي هست. كامل بگو user? world? group?
     
  12. balabala

    balabala کاربر قدیمی پرشین تولز

    تاریخ عضویت:
    ‏22 می 2005
    نوشته ها:
    7,344
    تشکر شده:
    1,314
    محل سکونت:
    یه خورده اونورتر
    بعد هم حداقل فایل web.config رو که میتونی اتچ کنی ببینم؟
     
  13. avajang.com .leftjee.ir.right
  14. H_R

    H_R مدیر بازنشسته

    تاریخ عضویت:
    ‏30 مارس 2005
    نوشته ها:
    3,285
    تشکر شده:
    15
    محل سکونت:
    North Pole
    اي بابا كنترل پنل به هاست چيكار داره ! تو اينو به خود كسي كه ازش هاستينگ خريدي گفتي و ازش پرسيدي ؟؟
    اگه بهش گفتي و نتونست جوابت رو بده بايد يا آدرس سايت رو درست حسابي به ما بدي ببنيم چيكار ميتونيم برات بكنيم يا بري توي انجمن هاي www.asp.net و اونجا بپرسی !
     
  15. ali00h

    ali00h Registered User

    تاریخ عضویت:
    ‏27 آگوست 2005
    نوشته ها:
    95
    تشکر شده:
    0
    باشه حتما اين كارو ميكنم بازم ممنون ازتون كه كمكم ميكنين
    اينم از web.config
    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>

    <system.web>


    <compilation defaultLanguage="vb" debug="true" />


    <customErrors mode="Off"/>


    <authentication mode="None" />

    <identity impersonate="true" />


    <authorization>
    <allow users="*" />

    </authorization>


    <trace enabled="false" requestLimit="10" pageOutput="false" traceMode="SortByTime" localOnly="true" />


    <sessionState
    mode="InProc"
    stateConnectionString="tcpip=127.0.0.1:42424"
    sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes"
    cookieless="false"
    timeout="20"
    />


    <globalization requestEncoding="utf-8" responseEncoding="utf-8" />

    </system.web>

    </configuration>
     
  16. balabala

    balabala کاربر قدیمی پرشین تولز

    تاریخ عضویت:
    ‏22 می 2005
    نوشته ها:
    7,344
    تشکر شده:
    1,314
    محل سکونت:
    یه خورده اونورتر
    من فايلت رو ديدم:

    ببيند اين impersonate تا اونجايي كه من فهميدم دسترسي به فايلها رو (خواندن و نوشتن) رو از حالت معمولي كه حفاظت شدس بر ميداره.

    به هرحال من يه نگاهي به منابع انداختم اين رو واست پيدا كردم حتما مشكلت همينه. شما بايد يوزر نيم و پسورد اف ته په يا هر پسوردي كه الان كار ميكنه رو قيد كنيد:

    کد:
    <identity impersonate="true" userName="username" password="password"/>
    ولی بنظرم اگر شما بتونید دسترسی به اون xml رو فقط نا محدود كنيد بهتره. يعني بريد world write able ش بكنيد و يك تست بزنيد اگر كار نكرد از اين روش استفاده كنيد.

    اميدوارم كه كده كار كنه...

    بلابلا! :rolleyes:
     
  17. ali00h

    ali00h Registered User

    تاریخ عضویت:
    ‏27 آگوست 2005
    نوشته ها:
    95
    تشکر شده:
    0
    من قبل از اينكه بيام اينجا سوال كنم اين كد امتحان كرده بودم ولي اينم نميشه يه همچين error ي ميده
    Access to the path "C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files\root\dd552974\b1763b1c\hash.web" is denied.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.UnauthorizedAccessException: Access to the path "C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files\root\dd552974\b1763b1c\hash.web" is denied.

    ASP.NET is not authorized to access the requested resource. Consider granting access rights to the resource to the ASP.NET request identity. ASP.NET has a base process identity (typically {MACHINE}\ASPNET on IIS 5 or Network Service on IIS 6) that is used if the application is not impersonating. If the application is impersonating via <identity impersonate="true"/>, the identity will be the anonymous user (typically IUSR_MACHINENAME) or the authenticated request user.

    از اينكه وقتتونو براي اين گذشتين ممنون
     
  18. ali00h

    ali00h Registered User

    تاریخ عضویت:
    ‏27 آگوست 2005
    نوشته ها:
    95
    تشکر شده:
    0
    چه جوري xml رو نامحدود كنم و اگرم با نامحدود كردن درست ميشه چرا توي هاست مجاني بدون نامحدود كردن كار ميكنه
     
  19. balabala

    balabala کاربر قدیمی پرشین تولز

    تاریخ عضویت:
    ‏22 می 2005
    نوشته ها:
    7,344
    تشکر شده:
    1,314
    محل سکونت:
    یه خورده اونورتر
    يعني چي كار ميكنه؟ شما گفته بوديد كه وقتي ميخوايد روش بنويسيد اررور ميده و ... خوب شايد دسترسي نوشتن روي اون فايل محدود هست. از توي پنل بريد فايل منجر و دسترسي write رو براش ست كنيد. بعد هم اون اررور رو روي هاست مجاني گرفتيد يا ماشين خودتون؟

    اگر ميشد كدي كه خطاي اصليه اين بحث رو ايجاد ميكنه ميگذاشتي خيلي خوب ميشد. ببينم از چيه اين خطا؟
     
  20. ali00h

    ali00h Registered User

    تاریخ عضویت:
    ‏27 آگوست 2005
    نوشته ها:
    95
    تشکر شده:
    0
    آقا مشكل حل شد مشكل از همون permission بود بازم ممنون كه كمكم كردين و وقتونو گذاشتين
     
  21. balabala

    balabala کاربر قدیمی پرشین تولز

    تاریخ عضویت:
    ‏22 می 2005
    نوشته ها:
    7,344
    تشکر شده:
    1,314
    محل سکونت:
    یه خورده اونورتر
    خوب خدارو شكر. :)

    موفق باشيد.
     
zarpopخرید بک لینک عسل طبیعی و گرده گل ایرانیfootbal