اختصاص دادن میزان مموری برای کارت گرافیک بصورت دستی !

شروع موضوع توسط H-C ‏17 آگوست 2012 در انجمن ویندوز

  1. H-C

    H-C مدیر بازنشسته مدیر انجمن

    تاریخ عضویت:
    ‏12 مارس 2008
    نوشته ها:
    4,618
    تشکر شده:
    407
    محل سکونت:
    Tehran
    سلام.

    من یک Dell Inspiron 5110-N دارم و چند روزی هست که یک مشکل جالب پیدا کردم. کارت گرافیک این لپ تاپ 1 گیگ هست و تا 4 گیگ هم میتونه شیر کنه.

    الان مشکل اینجاست که این Memory in Use ـش بصورت عادی بین 50-60 مگابایت هست. حالا یک سری بازی ها مثل PES 12 همون اولش میگه باید حداقل 128 مگ استفاده کنه مگرنا بازی رو درست اجرا نمیکنه و آخرش هم error میده و میاد بیرون !
    در صورت که همین لپ تاپ بازی هایی مثل بتمن رو خیلی راحت و بدون هیچ مشکلی اجرا میکنه.

    حالا میخواستم بدونم آیا راهی هست که بتونم بصورت دستی بهش بفهمونم در هر لحظه حداقل مثلا 150 مگ از حافظه رو بگیره ؟
     
    scanme از این نوشته تشکر کرده است.
  2. igimax

    igimax کاربر فعال کامپیوتر

    تاریخ عضویت:
    ‏17 سپتامبر 2004
    نوشته ها:
    3,407
    تشکر شده:
    1,256
    سلام H-C جان[​IMG]

    . عجيب!؟ اگر خودش 1GB يا 512MB حافظه به شكل Dedicate داره!؟ كه ديگه نبايد براي 128MB گير بده!؟ چون رفتم توي سايت Dell و مدل مشابه شما را يافتم و هردو كتاب راهنما و سرويسش را دنلود كردم و يك جستجويي توش كردم: http://support.euro.dell.com/support/edocs/systems/insN5110/en/sm/pdf/om_en.zip و http://support.euro.dell.com/support/edocs/systems/insN5110/en/sg/sg_en.zip

    . براساس كتابش كارت شما يا ATi با 1 گيگ حافظه انحصاريش يا NVidia با 512 مگ حافظه انحصاريش است! و ميشه حداكثر تا 1.6 گيگ افزايش داد و نه 4 گيگ!! Drivers and Downloads | Dell [Middle East]

    . حالا فرض كه نياز به تنظيم دستي باشد بايد در ابتداي شروع به كار سيستم با فشار كليد F2 به BIOS رفته و در آنجا مكان افزايش حافظه Share كارت گرافيك را در بين گزينه‌هايش يافته و آن را تغيير دهيد. ولي من روشي در كتابش براي تغيير اين حافظه اشتراكي از طريق ويندوز نيافتم!

    . موفق باشيد. [​IMG]

    خداحافظ
    IgImAx
    91/05/28
    [​IMG] [​IMG]
     
    scanme از این نوشته تشکر کرده است.
  3. H-C

    H-C مدیر بازنشسته مدیر انجمن

    تاریخ عضویت:
    ‏12 مارس 2008
    نوشته ها:
    4,618
    تشکر شده:
    407
    محل سکونت:
    Tehran
    سلام.

    ببین ظاهرا دوتا کارت گرفیک داره ! یکی نوشته Intel که زده حافظه اصلی 1024 و maximum رو هم زده 4096. حالا این اصلا مهم نیست چون گیر ما کلا سر 128 مگ هست این نرم افزار روانی داره به شعور من توهین میکنه و میگه کامپیوتر شما 64 مگ کلا حافظه گرافیک داره :دی

    ببین من نمیخوایم share رو افزایش بدم. این برای اینکه مال لپ تاپ هست و بخاطر سیو کردن پاور و این حرفها (احتمالا) قبل از اینکه نرم افزاری رو اجرا کنم استفاده ای نمیکنه از گرافیک و کلا 50-60 مگ هست (Memory in Use). حالا الان من میخوام این بازی لعنتی PES 12 رو بازی کنم و این احمق error میده چون فکر میکنه کل گرافیک من همونه !!!!

    در صورتی که خیلی از بازیها بدون مشکل بالا میان و بعد هم این میزان لازم از حافظه رو در اختیار میگیره و حیلی راحت MW3 و بتمن رو هم اجرا میکنه چه برسه به این بازی ژاپنی احمقانه ! اصلا یک چالشی شده برای من.

    مهم نیست از طریق ویندوز یا بایوس، میخوایم ببینم میشه به این (کامپیوتر) فهموند آقا شما داری میای بالا، 128 مگ حداقل استفاده کن یا نه !
     
  4. igimax

    igimax کاربر فعال کامپیوتر

    تاریخ عضویت:
    ‏17 سپتامبر 2004
    نوشته ها:
    3,407
    تشکر شده:
    1,256
    سلام H-C جان[​IMG]

    . آها! فهميدم مشكل چيه! چون شما دوتا كارت گرافيك داريد! يكي Intel HD3000 كه درون خود پروسسور هستو ديگريش ATi يا NVidia هست، بايد به روشي كارت دوم را به عنوان پيش فرض براي همه بازي‌ها يا 3D تنظيم نماييد....

    . حالا چون من اين چنين سيستمي دم دست ندارم بايد دست به دامن جستجوي گوگل بشم و سايت‌هايي را يافتم و از بينشون اين چند مورد بنظرم پاسخ سوال شما آمد:
    1) اول حتمن از سايت سازنده مادربورد خود آخرين نسخه درايور براي هر دو كارت گرافيك خود بيابيد و نصب و كنيد.

    2) حالا! راه اول: يكي در اينجا گفته بود، از طريق برنامه يا گزينه‌اي به نام optimus كه در درون برنامه همراه درايور كارت گرافيك Intel هست بايد كارت گرافيك پيشفرض را به كارت ذوم تغيير دهيد.

    3) راه دوم: در اين آدرس از youtube، در قسمت كامنت‌ها ايشون illusionestful در پاسخ ديگران نوشته كه:


    The problem is that PES 2012 deosn't use Nvidia but it uses intel
    to Update video cards go to dell support and on the drivers and download tap and download the latest updates for intel and nvidia
    install them and try the way i typed earlier

    **********************************************************************
    On the game EXE ( And the settings.exe , too ) right-click and choose Run with Graphics processor > High-Performance Card
    You will find that the game runs perfectly
    To make it Run this way all the time : From Run With Graphics processor choose set default card
    and set it to Nvidia High Performance
    Do it on both pes2012.exe and settings.exe
    Set the setting to Highest and Enjoy :D


    4) راه سوم: يكي در اينجا گفته بود، از طريق نصب آخرين نسخه درايور كارت دوم مثلن اگر NVidia هست از اين طريق كارت پيشفرض براي همه محاسبات و استفاده‌هاي 3D از كارت دوم استفاده كن:


    کد:
    1)Right click on desktop and choose "NVIDIA Control Settings"
    2)Look at left panel,under 
    3D Settings --> Manage 3D settings
    now you have 2 tabs GLOBAL SETTINGS and PROGRAM SETTINGS.
    Under GLOBAL SETTINGS tab under "Preferred graphics processor" choose  "High Performance NVIDIA processor". Don't change any other details on  that tab.
    Now,under PROGRAM SETTINGS tab
    click the button ADD which will ask you to browse the program you  want.Browse it to wherever your game is installed and find the  ".exe"  file.
    Example,c:\program files\NeedForSpeed\nfs.exe
    choose the ".exe" file and click OK,the under "select the preferred  graphics processor for this program" choose "High performance NVIDIA  processor".
    Click OK(if there is any) to save the changes and you're done.
    Next time when you open your game it will run by NVIDIA card.
    SCN003.jpg

    . ببخشيد كه تجربه عملي ندارم! و اميدوارم كه يكي از راه هاي فوق به شما جواب دهد! در اينترنت افراد زيادي همانند مشكل شما را داشتند! اكثرن پاسخشون به روز كردن درايو كارت گرافيك و بخصوص دوميش بوده ...!

    . موفق باشيد. [​IMG]

    خداحافظ
    IgImAx
    91/05/28
    [​IMG] [​IMG]
     
    AMD.POWER و HoP از این نوشته تشکر کرده اند.
  5. H-C

    H-C مدیر بازنشسته مدیر انجمن

    تاریخ عضویت:
    ‏12 مارس 2008
    نوشته ها:
    4,618
    تشکر شده:
    407
    محل سکونت:
    Tehran
    سلام. خیلی ممنون !

    راههای دوم و سوم رو قبلا امتحان کرده بود خودم ولی خب نه بهمراه آپدیت کردن کارت گرافیک. الان فایلش رو دانلود میکنم و نتیجه رو میگم در ساعات آینده !
     
    igimax از این نوشته تشکر کرده است.
  6. igimax

    igimax کاربر فعال کامپیوتر

    تاریخ عضویت:
    ‏17 سپتامبر 2004
    نوشته ها:
    3,407
    تشکر شده:
    1,256
    سلام H-C جان[​IMG]

    . آقا يك ايميل از پستي از دوست خوبمان HoP جان هم در اينجا بدستم رسيد كه وقتي چك كردم ديدم پستشان نيست! ايشان دو لينك عالي در درون پستشان بود كه من از پست دوم خيلي خوشم آمد كه معرفي همان كلمه نا آشنا به من به نام Optimus بود!

    . شايد براي شما يا ديگر دوستان هم مفيد باشد و مشكل گشا! اين لينك اول: Optimus Settings: power setting choices for increased performance. - Laptop Video Forum - Laptop - Dell Community اما لينك دوم كه معرفي همان تكنولوژي Optimus كمپاني Nvidia در سايت Dell است: nVidia Optimus Technology | Dell

    . موفق باشيد. [​IMG]

    خداحافظ
    IgImAx
    91/05/29
    [​IMG] [​IMG]
     
    HoP از این نوشته تشکر کرده است.
  7. H-C

    H-C مدیر بازنشسته مدیر انجمن

    تاریخ عضویت:
    ‏12 مارس 2008
    نوشته ها:
    4,618
    تشکر شده:
    407
    محل سکونت:
    Tehran
    سلام.

    آقا خیلی ممنون بابت کمکت. مشکل با آپدیت کردن و قرار دادن اون فایل exe بازی در پروسسور Nvidia حل شد. خیلی ممنون شدید !
     
    igimax از این نوشته تشکر کرده است.
  8. nasimrayane1390

    nasimrayane1390 کاربر تازه وارد

    تاریخ عضویت:
    ‏8 سپتامبر 2013
    نوشته ها:
    8
    تشکر شده:
    0
    سلام ميشه كمك كنيد در مورد افزايش حافظه گرافيك بصورت دستي؟
    تو ستينگ بايوس دنبال چي بگرردم؟ نيست كه نيست
     

این صفحه را با دیگران به اشتراک بگذارید


بک لینک