سایت ساز وبزیکسب درآمد

مشکل در ارسال با متدGET

شروع موضوع توسط mehrnet ‏13 مارس 2007 در انجمن PHP

  1. mehrnet

    mehrnet کاربر تازه وارد

    تاریخ عضویت:
    ‏3 اکتبر 2005
    نوشته ها:
    17
    تشکر شده:
    0
    سلام دوستان

    بوسیله متد GET یک متغیر را ارسال می کنیم
    ولی زمانیکه عملیات انجام شده و به صفحه بر میگردیم و دوباره این عمل را می خواهیم انجام دهیم
    متغیر قبلی در url موجود بوده و همینطور به مراتب اضافه میشود

    مثال:


    PHP:

    http
    ://mysite.com/test.php?ID=1&ID=2&ID=3&ID=4&ID=5&ID=6
    حالا:
    1- چرا این اتفاق می افتد
    2- چطور این مشکل را برطرف کنیم


    با تشکر​
     
  2. بازدیدیار - افزایش بازدید سایت و سیگنال های برندخرید بک لینک
  3. mehrnet

    mehrnet کاربر تازه وارد

    تاریخ عضویت:
    ‏3 اکتبر 2005
    نوشته ها:
    17
    تشکر شده:
    0
    منتظرم

    خیلی برام مهمه

    عجله دارم
     
  4. Mehdi

    Mehdi مدیر بازنشسته

    تاریخ عضویت:
    ‏1 آگوست 2004
    نوشته ها:
    5,558
    تشکر شده:
    49
    محل سکونت:
    Anywhere
    مشکل اینجاست , چجوری به صفحه برمیگردی؟ از چه روشی استفاده میکنی ؟
     
  5. miladmovie

    miladmovie مدیر بازنشسته کاربر فعال

    تاریخ عضویت:
    ‏25 دسامبر 2002
    نوشته ها:
    1,936
    تشکر شده:
    2
  6. seniorsajjad

    seniorsajjad Registered User

    تاریخ عضویت:
    ‏24 فوریه 2006
    نوشته ها:
    55
    تشکر شده:
    0
    محل سکونت:
    teh.
    با چند تا کد ساده امتحان کن ببین بازم همین طوره یا نه.

    مثلا:
    HTML:
    <form method="get">
        <input name="a">
        <input type="submit" value="Submit">
    </form>
    
    این نباید اون مشکلی رو که گفتی داشته باشه.....

    ببین توی هر مرحله واقعا از اول Submit میکنی یا نه.

    شاید کد جاوااسکریپت داشته باشی.

    همون طور که دوستمون گفت، بهتره کد رو بذاری تا بشه راحت تر بررسی کرد.​
     
عسل طبیعی و گرده گل ایرانیخرید و فروش اتوماتیک ارزهای الکترونیکی